Package Details

Package: finalcut-Y2A1eric+2
Product: finalcut
SVN Revision: 42477
Effective SVN Revision (incl depedencies): 42669
Effective latest update: 10/06/2016-19:26
Lifecycle: operational
Lifecycle (spec): operational
State: FATAL
Validation State: FATAL
Inherited State: ERROR
Build State: UNKNOWN
Test State: UNKNOWN

Dependency Graph

Remark: The dependency graph depicts for packages dependant on finalcut-Y2A1eric+2 only the latest version per product. Furthermore, test dependencies are not visible.

Listed Dependencies (main)

psfex-3.17.3+1 OK
sextractor-2.19.5+1 OK
scamp-2.1.1+7 OK
ProcessingFW-2.0.6+2 OK
qatoolkit-0.2.2+1 OK
pixcorrect-0.2.6+1 OK
imdetrend-7.3.5+2 ERROR
immask-0.5.2+5 OK

For a list with all direct and indirect dependencies and dependants (main and test) see all dependencies.

Messages:

FATAL INHERIT - Package depends on other package with erroneous status: (imdetrend-7.3.5+2 : ERROR)
FATAL CONFL - Package depends (directly or indirectly) on different package versions of the same product/configset: backportsSSLMatchHostname : backportsSSLMatchHostname-3.4.0.2+3, backportsSSLMatchHostname-3.4.0.2+2; dateutil : dateutil-1.5+6, dateutil-1.5+7; imsupport : imsupport-7.4.0+0, imsupport-7.3.3+1; d2to1 : d2to1-0.2.11+1, d2to1-0.2.11+2; despymisc : despymisc-1.0.2+0, despymisc-1.0.3+1; python : python-2.7.9+0, python-2.7.9+1; numpy : numpy-1.9.1+4, numpy-1.9.1+5; distribute : distribute-0.6.19+9, distribute-0.6.19+8; stsciDistutils : stsciDistutils-0.3.7+2, stsciDistutils-0.3.7+1; matplotlib : matplotlib-1.3.1+5, matplotlib-1.3.1+4; despyfits : despyfits-0.4.0+1, despyfits-0.4.0+0; scipy : scipy-0.14.0+6, scipy-0.14.0+7; tornado : tornado-4.1+3, tornado-4.1+2; nose : nose-1.3.0+7, nose-1.3.0+6; setuptools : setuptools-5.8+4, setuptools-5.8+3; pyparsing : pyparsing-2.0.3+3, pyparsing-2.0.3+2; certifi : certifi-14.05.14+3, certifi-14.05.14+2; despyastro : despyastro-0.3.7+1, despyastro-0.3.7+0; fitsio : fitsio-0.9.8rc1+3, fitsio-0.9.8rc1+4; pyfits : pyfits-3.3+3, pyfits-3.3+4.

All Reports

Table File

1 # DESDM image modules
2 setupRequired(pixcorrect 0.2.6+1)
3 setupRequired(imdetrend 7.3.5+2)
4 setupRequired(immask 0.5.2+5)
5
6 # QA/Assesment
7 setupRequired(qatoolkit 0.2.2+1)
8
9 # Astromatic (stiff is loaded by qatoolkit)
10 setupRequired(sextractor 2.19.5+1)
11 setupRequired(scamp 2.1.1+7)
12 setupRequired(psfex 3.17.3+1)
13
14 # Framework -- now simpler
15 setupRequired(ProcessingFW 2.0.6+2)
16 # I will load:
17 # - QCFramework
18 # - FileMgmt loads:
19 # + DatabaseAps
20 # + IntegrationUtils
21
22 # Definition for Production Pipeline
23 envPrepend(DESDM_PIPEPROD, "finalcut")
24 envPrepend(DESDM_PIPEVER, "Y2A1eric+2")

Build File

  (empty file)