Package Details

Package: galsim-1.4.2+7
Product: galsim
SVN Revision: 45968
Effective SVN Revision (incl depedencies): 45968
Effective latest update: 18/07/2017-09:21
Lifecycle: operational
Lifecycle (spec): operational
State: OK
Validation State: OK
Inherited State: OK
Build State: OK
Test State: OK

Dependency Graph

Remark: The dependency graph depicts for packages dependant on galsim-1.4.2+7 only the latest version per product. Furthermore, test dependencies are not visible.

Listed Dependencies (main)

pyyaml-3.11+2 OK
pyfits-3.3+5 OK
scipy-0.14.0+8 OK
fftw_double-3.3.2+6 OK
future-0.15.0+2 OK
tmv-0.72+2 OK
astropy-1.1.2+2 OK
boost-1.55.0+0 OK

For a list with all direct and indirect dependencies and dependants (main and test) see all dependencies.

Messages:

OK Package validated, build and test status ok.

All Reports

build desbuild 18/07/2017-09:27 OK

Table File

1 # setupRequired(scons 2.3.4+2)
2
3 setupRequired(boost 1.55.0+0)
4
5 # setupRequired(fftw 3.3.2+6)
6
7 setupRequired(fftw_double 3.3.2+6)
8 setupRequired(astropy 1.1.2+2)
9 setupRequired(tmv 0.72+2)
10 setupRequired(pyfits 3.3+5)
11 setupRequired(future 0.15.0+2)
12 setupRequired(pyyaml 3.11+2)
13 setupRequired(scipy 0.14.0+8)
14
15
16
17 envAppend(LD_LIBRARY_PATH, ${PRODUCT_DIR}/lib)
18 if (FLAVOR == DarwinX86 || FLAVOR == Darwin) {
19 envPrepend(DYLD_LIBRARY_PATH, ${PRODUCT_DIR}/lib)
20 }
21
22 envAppend(PATH, ${PRODUCT_DIR}/bin)
23
24 envPrepend(PYTHONPATH, ${PRODUCT_DIR}/lib/python2.7/site-packages)

Build File

1 #!/usr/bin/env bash
2
3 curl -O $EXTERNAL/$PRODUCT/GalSim-$VERSION.tar.gz
4 tar xzf GalSim-$VERSION.tar.gz
5 cd GalSim-$VERSION
6
7 if [[ $FLAVOR =~ Darwin ]] ; then
8 export CXX=c++
9 elif [[ $FLAVOR =~ Linux ]] ; then
10 export CXX=g++
11 else
12 echo "ERROR: EUPS FLAVOR:$FLAVOR not supported"
13 exit
14 fi
15
16 scons CXX=g++ FFTW_DIR=${FFTW_DOUBLE_DIR}
17 scons install PREFIX=$PRODUCT_DIR
18
19 # scons test