Report Details

Package: matplotlib-1.4.3+0
Report Type: build
SVN Revision: 47651
Generated on: desbuild
Generated at: Sept. 17, 2018, 10:34 p.m.
Result: ERROR

Messages

ERROR eups undeclare: Product matplotlib 1.4.3+0 for Linux64 not found
ERROR BUILD ERROR! From build log:
ERROR copying lib/matplotlib.egg-info/top_level.txt -> build/bdist.linux-x86_64/egg/EGG-INFO
ERROR writing build/bdist.linux-x86_64/egg/EGG-INFO/native_libs.txt
ERROR creating dist
ERROR creating 'dist/matplotlib-1.4.3-py2.7-linux-x86_64.egg' and adding 'build/bdist.linux-x86_64/egg' to it
ERROR removing 'build/bdist.linux-x86_64/egg' (and everything under it)
ERROR Creating /des002/devel/eeups/ci_build_desbuild/Linux64/matplotlib/1.4.3+0/python/site.py
ERROR Processing matplotlib-1.4.3-py2.7-linux-x86_64.egg
ERROR creating /des002/devel/eeups/ci_build_desbuild/Linux64/matplotlib/1.4.3+0/python/matplotlib-1.4.3-py2.7-linux-x86_64.egg
ERROR Extracting matplotlib-1.4.3-py2.7-linux-x86_64.egg to /des002/devel/eeups/ci_build_desbuild/Linux64/matplotlib/1.4.3+0/python
ERROR Adding matplotlib 1.4.3 to easy-install.pth file
ERROR
ERROR Installed /des002/devel/eeups/ci_build_desbuild/Linux64/matplotlib/1.4.3+0/python/matplotlib-1.4.3-py2.7-linux-x86_64.egg
ERROR Processing dependencies for matplotlib==1.4.3
ERROR Searching for pbr>=0.11
ERROR Reading http://pypi.python.org/simple/pbr/
ERROR Couldn't find index page for 'pbr' (maybe misspelled?)
ERROR Scanning index of all packages (this may take a while)
ERROR Reading http://pypi.python.org/simple/
ERROR No local packages or download links found for pbr>=0.11
ERROR error: Could not find suitable distribution for Requirement.parse('pbr>=0.11')
ERROR eups distrib: Failed to build matplotlib-1.4.3+0.build: Command:
ERROR export EUPS_PATH=/des002/devel/eeups/ci_build_desbuild
ERROR (cd /des002/devel/eeups/ci_build_desbuild/EupsBuildDir/Linux64/matplotlib-1.4.3+0 &&
ERROR setup --just --type=build openblas 0.2.19+2 &&
ERROR setup --just --type=build sqlite 3080002+0 &&
ERROR setup --just --type=build libpng 1.4.14+0 &&
ERROR setup --just --type=build freetype 2.5.5+0 &&
ERROR setup --just --type=build tcl 8.5.17+0 &&
ERROR setup --just --type=build tk 8.5.17+1 &&
ERROR setup --just --type=build python 2.7.9+1 &&
ERROR setup --just --type=build six 1.10.0+0 &&
ERROR setup --just --type=build setuptools 18.0+1 &&
ERROR setup --just --type=build mock 2.0.0+0 &&
ERROR setup --just --type=build pyparsing 2.0.3+3 &&
ERROR setup --just --type=build backportsSSLMatchHostname 3.4.0.2+5 &&
ERROR setup --just --type=build certifi 14.05.14+5 &&
ERROR setup --just --type=build tornado 4.1+4 &&
ERROR setup --just --type=build dateutil 1.5+10 &&
ERROR setup --just --type=build cython 0.21.2+3 &&
ERROR setup --just --type=build numpy 1.10.4+4 &&
ERROR setup --just --type=build nose 1.3.0+7 &&
ERROR setup --just --type=build distribute 0.6.19+9 &&
ERROR setup --just --type=build pytz 2015.7+2 &&
ERROR set -o errexit
ERROR set -o nounset
ERROR shopt -s extglob
ERROR EXTERNAL=http://desbuild.cosmology.illinois.edu/eeups/webservice/resources
ERROR PRODUCT=matplotlib
ERROR VERSION=1.4.3
ERROR PKG_VERSION=0
ERROR FULL_VERSION=1.4.3+0
ERROR SVNROOT='https://dessvn.cosmology.illinois.edu/svn/desdm/devel'
ERROR SVN_PATH=tags/1.4.3+0
ERROR FLAVOR=$(eups flavor)
ERROR if [[ $FLAVOR =~ -icc ]] ; then ICC=1 ; else ICC=0; fi
ERROR PRODUCT_DIR=$(eups path 0)/$FLAVOR/$PRODUCT/${FULL_VERSION}
ERROR mkdir -p $PRODUCT_DIR
ERROR rm -rf $PRODUCT_DIR/*
ERROR find . -not -regex "./[^/]*.log" -delete
ERROR setup --keep --type=build tornado 4.1+4
ERROR setup --keep --type=build numpy 1.10.4+4
ERROR setup --keep --type=build freetype 2.5.5+0
ERROR setup --keep --type=build libpng 1.4.14+0
ERROR setup --keep --type=build pyparsing 2.0.3+3
ERROR setup --keep --type=build dateutil 1.5+10
ERROR setup --keep --type=build nose 1.3.0+7
ERROR setup --keep --type=build distribute 0.6.19+9
ERROR setup --keep --type=build mock 2.0.0+0
ERROR setup --keep --type=build pytz 2015.7+2
ERROR setup --keep --type=build six 1.10.0+0
ERROR wget $EXTERNAL/$PRODUCT/$PRODUCT-$VERSION.tar.gz
ERROR tar xzf $PRODUCT-$VERSION.tar.gz
ERROR mkdir -p $PRODUCT_DIR/python
ERROR cd $PRODUCT-$VERSION
ERROR export PYTHONPATH=$PRODUCT_DIR/python:$PYTHONPATH
ERROR python setup.py install --prefix=$PRODUCT_DIR --install-lib=$PRODUCT_DIR/python) >> /des002/devel/eeups/ci_build_desbuild/EupsBuildDir/Linux64/matplotlib-1.4.3+0/matplotlib-1.4.3+0.build.log 2>&1
ERROR exited with code 1
ERROR Required product openblas 0.2.19+2 is already installed; use --force to reinstall
ERROR Required product sqlite 3080002+0 is already installed; use --force to reinstall
ERROR Required product libpng 1.4.14+0 is already installed; use --force to reinstall
ERROR Required product freetype 2.5.5+0 is already installed; use --force to reinstall
ERROR Required product tcl 8.5.17+0 is already installed; use --force to reinstall
ERROR Required product tk 8.5.17+1 is already installed; use --force to reinstall
ERROR Required product python 2.7.9+1 is already installed; use --force to reinstall
ERROR Required product six 1.10.0+0 is already installed; use --force to reinstall
ERROR Assigning Server Tag MEPipeline-Y3A2dev to dependency six 1.10.0+0
ERROR Required product setuptools 18.0+1 is already installed; use --force to reinstall
ERROR Required product mock 2.0.0+0 is already installed; use --force to reinstall
ERROR Required product pyparsing 2.0.3+3 is already installed; use --force to reinstall
ERROR Required product backportsSSLMatchHostname 3.4.0.2+5 is already installed; use --force to reinstall
ERROR Required product certifi 14.05.14+5 is already installed; use --force to reinstall
ERROR Required product tornado 4.1+4 is already installed; use --force to reinstall
ERROR Required product dateutil 1.5+10 is already installed; use --force to reinstall
ERROR Required product cython 0.21.2+3 is already installed; use --force to reinstall
ERROR Required product numpy 1.10.4+4 is already installed; use --force to reinstall
ERROR Required product nose 1.3.0+7 is already installed; use --force to reinstall
ERROR Required product distribute 0.6.19+9 is already installed; use --force to reinstall
ERROR Required product pytz 2015.7+2 is already installed; use --force to reinstall
ERROR Installing matplotlib 1.4.3+0 for generic...

Attachments

build.log (https://dessvn.cosmology.illinois.edu/svn/desdm/devel/eupsScripts/reports/desbuild/build_matplotlib-1.4.3+0_47651_20180917223410/build.log)